网站升级PHP7.2报错Error establishing a database connection | 【韩涛博客】

网站升级PHP7.2报错Error establishing a database connection

今天登陆Wordpress后台提示让我升级PHP版本,我一直使用的是PHP5.6版本,总之意思就是当前版本不太安全了。我就进阿里云的后台切换了一下版本:

网站升级PHP7.2报错Error establishing a database connection

然后:

网站升级PHP7.2报错Error establishing a database connection

是的没错,然后就报错了,错误信息是:Error establishing a database connection。这个错误信息就是说数据库没有连上,按说是只切换了一下PHP版本[aru_39]我进后台又仔细看了一下,阿里其实已经有很明确的提示了:因为切换了版本所以对应的数据库加密模式也就发生了变化,所以我进数据库管理界面进行了密码重置,且把加密模式调整成41位加密,刷新后问题解决!

网站升级PHP7.2报错Error establishing a database connection

广告

发表评论 取消回复
表情 图片 链接 代码

  1. boke112联盟

    阿里云虚拟主机切换PHP到高版本之后,数据库也要改一下加密方式或升级数据库,这个问题不到。不过升级数据库的时候一定要先备份数据库。

    • 韩涛Hunter
      韩涛Hunter 站长

      @boke112联盟是呢,我就是忘了切换加密方式了,所以给报错了

  2. 流年伴夏

    数据库版本升级是这样...没办法

分享
×
订阅图标按钮